We're investigating an issue with FlippingBook website
Incident Report for FlippingBook
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 09:22 EDT
Investigating
We are seeing reports that clients cannot access our website. We are currently investigating this issue.

We understand that this is very inconvenient and this is a top-priority issue for us and will keep you informed about any progress
Posted Apr 17, 2024 - 09:17 EDT
This incident affected: Public Website (flippingbook.com).