We are experiencing problems with using FlippingBook Online accounts

Incident Report for FlippingBook

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 14:56 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2026 - 14:48 EDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 17, 2026 - 14:44 EDT

Identified

There is a confirmed problem with the using FlippingBook Online accounts. This can result in being unable to log in or using the account when you are logged in. Our engineers are working on a solution.

This is a top-priority issue for us and will keep you informed about any progress.
Posted Mar 17, 2026 - 14:43 EDT
This incident affected: FlippingBook Online (Flipbooks conversion, Account).