The problem with the FlippingBook Online infrastructure is resolved, everything should be working fine again. Please accept our apologies for the inconvenience. We will update this issue later with a post mortem analysis.
Posted Apr 15, 2025 - 10:32 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 10:30 EDT
Identified
There is a confirmed problem with out FlippingBook Online infrastructure, affecting accounts and flipbooks. All hands are on deck for this critical issue and we'll keep you updated on any progress soon.
Posted Apr 15, 2025 - 10:29 EDT
This incident affected: FlippingBook Online (Flipbooks, Flipbooks conversion, Account, Stats).