We're investigating an issue with FlippingBook Online accounts

Incident Report for FlippingBook

Resolved

This incident has been resolved.
Posted Mar 07, 2023 - 20:09 EST

Investigating

We are seeing reports that clients cannot enter their FlippingBook Online accounts or encounter problems after they have logged in. We are currently investigating this issue.

We understand that this is very inconvenient and this is a top-priority issue for us and will keep you informed about any progress
Posted Mar 07, 2023 - 19:38 EST
This incident affected: FlippingBook Online (Flipbooks, Flipbooks conversion, Account, Stats).