Some pages on the flippingbook.com website might not be opening
Incident Report for FlippingBook
Resolved
The problem with the Pricing page and the Subscription section in the accounts has been resolved. If you are still encountering any problems, then please log out of your account, restart your browser, and then log in again. If you still encounter any problems then please contact our support team (support@flippingbook.com).
Posted May 14, 2024 - 13:40 EDT
Investigating
The Pricing page and the Subscription section in the accounts are not working correctly at the moment. We are looking into this and will be providing the updates as soon as possible
Posted May 14, 2024 - 13:04 EDT
This incident affected: FlippingBook Online (Account) and Public Website (flippingbook.com).