Unstable FlippingBook Cloud performance

Incident Report for FlippingBook

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 04:57 EDT

Monitoring

There have been some brief outages of FlippingBook Cloud-hosted flipbooks. We have already implemented a fix, and the flipbooks should be back online now. If you are still experiencing issues even after clearing the cache of your browser, please contact support@flippingbook.com for the assistance.
Posted Jun 02, 2025 - 04:52 EDT
This incident affected: FlippingBook Publisher (FlippingBook Publisher Cloud (cld.bz)).