Chat support temporarily unavailable

Incident Report for FlippingBook

Update

We are continuing to work on a fix for this issue.
Posted Sep 05, 2025 - 06:15 EDT

Identified

At this moment, we can't assist you through live chat. We will be happy to help you through our other channels mentioned at https://flippingbook.com/contacts. We expect to be able to help you over chat again by Tuesday, Sep 9, at the latest.
Posted Sep 05, 2025 - 06:13 EDT
This incident affects: Sales & Support customer contact systems.