Direct links to flipbooks and Customize menu are not working
Incident Report for FlippingBook
Resolved
This incident has been resolved.
Posted Sep 17, 2022 - 06:07 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2022 - 05:51 EDT
Investigating
The links to the flipbooks and the Customize menu in the account have stopped working. We are looking at the problem and will be providing updates.
Posted Sep 17, 2022 - 05:27 EDT
This incident affected: FlippingBook Online (Flipbooks, Account).