Issue with Uploading or Updating Flipbooks to FlippingBook Cloud in Publisher

Incident Report for FlippingBook

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 19:56 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2025 - 19:45 EDT

Investigating

We are currently investigating an issue where uploading or updating flipbooks to the FlippingBook Cloud via FlippingBook Publisher is not working as expected.

Some users are experiencing failures during the upload process, or are unable to update existing flipbooks. In some cases, the process does not complete or results in error messages.

We understand how disruptive this is and want to assure you that resolving this is a top priority for our team. We’ll continue to share updates here as we make progress.
Posted Apr 03, 2025 - 19:31 EDT
This incident affected: FlippingBook Publisher (FlippingBook Publisher Cloud (cld.bz)).