A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2024 - 10:36 EST
Investigating
There is a problem with accessing FlippingBook Online at the moment. We are aware of the issue and our team is already looking into the matter. Thank you for your patience.
Posted Dec 11, 2024 - 10:36 EST
This incident affected: FlippingBook Online (Flipbooks, Flipbooks conversion, Account, Stats).