Issue affecting FlippingBook Publisher logins

Incident Report for FlippingBook

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 21:41 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2026 - 21:37 EDT

Update

A fix has now been implemented. We’re monitoring the system to ensure everything is working as expected.
Posted Mar 12, 2026 - 19:41 EDT

Investigating

We’re currently experiencing an issue affecting FlippingBook Publisher logins, and it may not be possible to sign in right now. Our team is already investigating.
Posted Mar 12, 2026 - 18:29 EDT
This incident affected: FlippingBook Publisher (Log in).