Chat function is down
Incident Report for FlippingBook
Resolved
This incident has been resolved.
Posted Sep 21, 2021 - 08:52 EDT
Identified
Your chats are not visible to our agents - that's why you get no reply to your chats!
Posted Sep 21, 2021 - 08:47 EDT
This incident affected: Sales & Support customer contact systems.