We're experiencing issues with the FlippingBook Online and FlippingBook Publisher account pages
Incident Report for FlippingBook
Resolved
This incident has been resolved.
Posted Jun 28, 2024 - 09:42 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 28, 2024 - 09:38 EDT
Investigating
The users might be experiencing issues while trying to access FlippingBook Online and FlippingBook Publisher account pages on our website. We are looking into the problem and will be providing the updates ASAP.
Posted Jun 28, 2024 - 09:33 EDT
This incident affected: FlippingBook Publisher (Log in) and FlippingBook Online (Account).