We are experiencing problems with showing flipbooks
Incident Report for FlippingBook
Resolved
After the earlier problems we had with showing flipbooks, we see that the situation has fully stabilized and everything should work fine. If you are still experiencing any problems, reload the page or restart your browser. If you still encounter any problems then please contact our support team (support@flippingbook.com) immediately.
Posted May 02, 2024 - 06:17 EDT
Monitoring
We see that flipbooks start working normally again, but are still keeping a close eye on the situation.
Posted May 02, 2024 - 06:12 EDT
Identified
There is a confirmed problem with reading flipbooks. When readers open a link to a flipbook, they either see only the preloader, an empty page, or an error message. This is the core service that we offer and is a critical priority issue for us. Everyone involved in FlippingBook is on red alert to solve this ASAP. Updates follow as soon as available.
Posted May 02, 2024 - 06:08 EDT
This incident affected: FlippingBook Online (Flipbooks).