Unstable FlippingBook Cloud performance

Incident Report for FlippingBook

Resolved

The incident has been resolved. We will be continuing to monitor and fix any issues that will arise today prior to the scheduled maintenance of FlippingBook Cloud
Posted Jun 02, 2025 - 06:49 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2025 - 06:44 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 02, 2025 - 06:39 EDT

Identified

We've noticed that FlippingBook Cloud-hosted flipbooks are not opening at the moment. Our team is already working on fixing the issue and restoring the availability of the content.
Posted Jun 02, 2025 - 06:39 EDT
This incident affected: FlippingBook Publisher (FlippingBook Publisher Cloud (cld.bz)).