We are experiencing problems with showing flipbooks
Incident Report for FlippingBook
Resolved
After the earlier problems we had with showing flipbooks, we see that the situation has fully stabilized and everything should work fine. If you are still experiencing any problems, reload the page or restart your browser. If you still encounter any problems then please contact our support team (support@flippingbook.com) immediately.
Posted Apr 25, 2024 - 11:22 EDT
Monitoring
It looks like the problem with our FlippingBook Online infrastructure has been resolved. We're keeping an eye on it, but Flipbooks should open normally again and you should be able to access your account. If you are still experiencing problems, then please restart your browser or try opening an incognito tab. If the problem persists, then contact our support staff immediately.
Posted Apr 25, 2024 - 11:10 EDT
Identified
There is a confirmed problem with reading flipbooks. When readers open a link to a flipbook, they either see only the preloader, an empty page, or an error message. This is the core service that we offer and is a critical priority issue for us. Everyone involved in FlippingBook is on red alert to solve this ASAP. Updates follow as soon as available.
Posted Apr 25, 2024 - 11:01 EDT
This incident affected: FlippingBook Online (Flipbooks).