We are experiencing problems with Statistics

Incident Report for FlippingBook

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 15:41 EDT

Identified

There is a confirmed problem with statistics in the FlippingBook Online accounts. When requesting stats, you may receive them with delays or receive error messages. This issue is related to an outage on Amazon AWS.
Posted Oct 20, 2025 - 13:10 EDT
This incident affected: FlippingBook Online (Stats).