We are experiencing problems with FlippingBook Online
Incident Report for FlippingBook
Resolved
After the earlier problems we had with showing flipbooks, we see that the situation has fully stabilized and everything should work fine. If you are still experiencing any problems, reload the page or restart your browser. If you still encounter any problems then please contact our support team (support@flippingbook.com) immediately.
Posted Jul 20, 2021 - 05:00 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 20, 2021 - 04:58 EDT
Monitoring
We see that flipbooks start working normally again and it is possible to log in to the account. We are still keeping a close eye on the situation.
Posted Jul 20, 2021 - 04:57 EDT
Identified
There is a confirmed problem with reading flipbooks and FlippingBook Online accounts. When readers open a link to a flipbook, they either see an error message. This is the core service that we offer and is a critical priority issue for us. Everyone involved in FlippingBook is on red alert to solve this ASAP. Updates follow as soon as available.
Posted Jul 20, 2021 - 04:47 EDT
This incident affected: FlippingBook Online (Flipbooks, Flipbooks conversion, Account, Stats).