We are experiencing problems with using FlippingBook Online accounts
Incident Report for FlippingBook
Resolved
The problem with using FlippingBook Online accounts has been resolved. If you are still encountering any problems, then please log out of your account, restart your browser, and then log in again. If you still encounter any problems then please contact our support team (support@flippingbook.com).
Posted Sep 15, 2022 - 02:30 EDT
Monitoring
It looks like the problem with logging in to accounts is solved. If you encountered any issues, then you can try again. If you are still encountering any problems, then please log out of your account and/or close your browser and then log in again. For now, we keep monitoring the situation.
Posted Sep 15, 2022 - 02:09 EDT
Identified
There is a confirmed problem with the using FlippingBook Online accounts. This can result in being unable to log in or using the account when you are logged in. Our engineers are working on a solution.

This is a top-priority issue for us and will keep you informed about any progress.
Posted Sep 15, 2022 - 02:02 EDT
This incident affected: FlippingBook Online (Account).