We're investigating an issue with flipbooks not working correctly
Incident Report for FlippingBook
Resolved
This incident has been resolved.
Posted May 03, 2024 - 14:47 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 03, 2024 - 14:40 EDT
Investigating
We are receiving reports that flipbooks are not working correctly when readers open the direct links. This is the core service that we offer and is a critical priority issue for us. Everyone involved in FlippingBook has been put on red alert to investigate this. Updates will follow ASAP.
Posted May 03, 2024 - 14:35 EDT
This incident affected: FlippingBook Publisher (FlippingBook Publisher Cloud (cld.bz)).